product.dat file not found

Stuck at some Point? Your Lumia is already dead? Maybe others can help you!
Post Reply
Posts: 1
Joined: Wed Nov 27, 2019 2:10 pm

product.dat file not found

Post by wbl » Thu Nov 28, 2019 1:50 am


In the process of flashing WOA on my Lumia 950 XL and then uninstalling WOA and flashing back to just W10M, I somehow managed to erase the Product Code and IMEI numbers from my devices memory. So while the device works fine otherwise, the lack of an IMEI means I can no longer connect to cellular networks. I tried flashing again using:

Code: Select all

thor2 -mode uefiflash -ffufile "ffufile.ffu" -productcodeupdate 059W8M3 -do_full_nvi_update -do_factory_reset
The flash worked fine, but it was unable to update the product code and yielded the following error message:

Code: Select all

[Factory reset result] 0
Factory reset done
[THOR2_flash_state] Updating product code
Write product code ( 059W8M3 )

Write parameter to device via UEFI Flash App
Device cannot find product.dat file.

[Product code update result] 84122
Rebooting device
Sending reset command to device
Reset command sent successfully.
Operation took about 1 minute, 12 seconds. Average transfer speed was 38.84 MB/s.

I know this is more of a W10M issue and not a WOA issue, but this seems to be the most active current Lumia 950 forum. I've searched online for a couple of days for answers and have been unsuccessful. I've tried using thor2, WPinternals, and Windows Device Recovery Tool. If anyone has any suggestions or directions to point me in, please let me know.

Thanks in advance,
0 x

Post Reply